mac git xcrun error active developer path 错误_Swift

分享到:

一:情景:

在mac下使用git;xcode4.6的环境时,需要安装command line tools ,但是在装了xcode5之后,就不需要安装command line tools了,默认已经集成了;但是我先装了,xcode4.6后来又安装了xcode5也就是,我mac上安装了两个版本的xocde但是在终端下使用git时,出现了错误如下:

二:错误

    xcrun: error: active developer path ("/Users/apple/Desktop/Xcode5.app/Contents/Developer") does not exist, use xcode-select to change

三:解决方法:

在终端下:

sudo xcode-select -switch /Applications/Xcode5.app/Contents/Developer

注:上面的xcode5.app根据情况,因为我的xcode安装之后,改了名字叫xcode5所以这里是,xcodee5.app如果你没有

昵    称:
验证码:

相关文档: